Installation#

This page outlines the steps to install OptiFine for any version on any operating system.

Pre-requisites#

Before installing OptiFine, you may need to install some things first.

Java runtime#

You may need to install a Java runtime above JRE version 8. It is not recommended to use Oracle’s Java. Instead, use Adoptium’s (formerly AdoptOpenJDK) Java runtime.

You can choose to install either Java 8, or Java 17; both work with the OptiFine installer.

  1. Go to https://adoptium.net/?variant=openjdk17&jvmVariant=hotspot

  2. Click “Latest release”

  3. Run the downloaded file

  1. Go to https://adoptium.net/?variant=openjdk8&jvmVariant=hotspot

  2. Click “Latest release”

  3. Run the downloaded file

Jarfix#

Important

This is only for Windows.

If you have the Java runtime installed, but can’t open .JAR files with it, you need to install Jarfix. Jarfix is an application that fixes the file association on Windows.

Download it from https://johann.loefflmann.net/en/software/jarfix/index.html and run it.

Installing with the Vanilla client#

To install OptiFine for a version, that same Vanilla version must be installed and ran beforehand. If the version is not installed, or if it has not been played before, OptiFine will not install.

  1. With any browser, go to https://optifine.net/downloads.

  2. Find the version of Minecraft you wish to install OptiFine for
    You need to click “Show all versions” near the bottom to see all versions.
  3. Click the “(mirror)” link. It should be the second one.
    The blue “Download” button works fine, but the ad page that shows may mislead players into downloading the wrong file.
  4. Save and download the .jar file. It should now be in your Downloads folder on your computer.

  5. Open the .jar. file that was just downloaded.

  6. Follow the instructions and click “Install”.

  7. Open the Minecraft launcher and select the OptiFine profile, and click “Play”.

Installing with MultiMC#

Read https://github.com/MultiMC/Launcher/wiki/MultiMC-and-OptiFine#minecraft-versions-without-forge-or-fabric.

Installing with Forge#

Note

This tutorial does not explain how to install Forge.

  1. Download and install Minecraft Forge for the version you want

  2. With any browser, go to https://optifine.net/downloads

  3. Find the version of Minecraft you wish to install OptiFine for.
    You need to click “Show all versions” near the bottom to see all versions.
    Ensure that your version has a compatible Forge version listed.
  4. Click the “(mirror)” link. It should be the second one.
    The blue “Download” button works fine, but the ad page that shows may mislead players into downloading the wrong file.
  5. Save and download the .jar file. It should now be in your Downloads folder on your computer.

  6. Open your Downloads folder in a file manager.

  7. From here on, process depends on your OS:

  1. Press Windows + R, and inside of the Run window, type %AppData%\.minecraft\.

  1. Open the Spotlight search by either:
    Clicking the Spotlight icon in the menu bar.
    Pressing Command + Space.
  2. In the Spotlight window, type ~/library/Application Support/minecraft/.

  1. Open a file manager.

  2. Change the path to ~/.minecraft/.

  1. If there is no “mods” folder in .minecraft, create one (all lowercase; case-sensitive).

  2. Drag the OptiFine jar from the Downloads folder into the “mods” folder.

  3. Launch the game with Forge.

_images/forge_compat.png

Ensure that “Forge” has a number for your version, or else it will not install for Forge.#


🆚️ This documentation assumes the latest OptiFine version. Notes are not made for legacy versions (1.8).
🔙️ This documentation is updated to commit 8410499f.
©️ This file is offered without any copyright restrictions. Please copy and modify it to suit your needs. Credit is optional, but appreciated.